EOS Voice Chat Issue
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Jun 25, 2024 - 23:38 UTC
Investigating
We're investigating an issue impacting Voice Chat for Epic Online Services. We'll update this incident when we have more info.
Posted Jun 25, 2024 - 22:42 UTC
This incident affected: Epic Online Services (Voice).