Rocket League - 1/25/2021
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Jan 26, 2021 - 04:28 UTC
Investigating
We are currently investigating this issue.
Posted Jan 26, 2021 - 03:48 UTC
This incident affected: Rocket League (Login, Game Services, Matchmaking, Stats and Leaderboards, Item Shop, Parties, Friends, and Messaging).