x
Get the
Atom Feed
or
RSS Feed
.
Battle Royale Challenges Appearing Incomplete
Incident Report for
Epic Games Public
Resolved
This incident is now resolved and Challenges will show your correct progress.
Posted
7
months ago.
Aug
08
,
2018
-
02:20
UTC
Investigating
We are investigating a visual issue with challenges appearing as incomplete. Progression will show when viewing the challenges in detail.
Posted
7
months ago.
Aug
07
,
2018
-
10:41
UTC
×
Subscribe to Incident
Subscribe to updates for
Battle Royale Challenges Appearing Incomplete
via .