Matchmaking Issues
Incident Report for Epic Games Public
Resolved
Matchmaking has returned to a healthy state.
Posted 5 days ago. Nov 07, 2018 - 20:25 UTC
Identified
We’re currently experiencing matchmaking issues that may result in longer queue times. We're working on a fix.
Posted 5 days ago. Nov 07, 2018 - 16:50 UTC