Downtown Drop LTM - Stability Issues
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted 3 months ago. May 23, 2019 - 01:48 UTC
Investigating
We're investigating an issue with the Downtown Drop LTM that's preventing players from collecting coins or using items.

We'll let you know once we've solved this problem.
Posted 3 months ago. May 22, 2019 - 13:01 UTC