Login Issues
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted 24 days ago. Jan 29, 2019 - 05:02 UTC
Monitoring
We are observing recovery to Epic Games services as a result of the fixes we've implemented, and will continue to monitor to ensure full recovery.
Posted 24 days ago. Jan 29, 2019 - 04:34 UTC
Update
We are continuing to work on a fix for this login issue. We will continue to provide updates as they become available.
Posted 24 days ago. Jan 29, 2019 - 04:18 UTC
Update
We are continuing to work on a fix for this issue.
Posted 24 days ago. Jan 29, 2019 - 01:53 UTC
Identified
We have identified an issue with logins and some players may have trouble connecting to Epic Games services. We will keep you updated as we work towards a resolution.
Posted 24 days ago. Jan 29, 2019 - 01:51 UTC
This incident affected: Fortnite (Game Services, Login, Store) and Epic Games store.