Login Issue
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Mar 17, 2018 - 11:37 UTC
Monitoring
Login services have recovered and we are continuing monitoring to ensure full recovery.
Posted Mar 17, 2018 - 11:31 UTC
Identified
We are working to correct the login issues.
Posted Mar 17, 2018 - 11:26 UTC
Investigating
We are aware of and currently investigating login issues.
Posted Mar 17, 2018 - 11:11 UTC