Service Issues
Incident Report for Epic Games Public
Resolved
The issue has been resolved.
Posted Mar 16, 2018 - 20:30 UTC
Monitoring
We're seeing recovery for those backend issues and are continuing to monitor.
Posted Mar 16, 2018 - 20:15 UTC
Investigating
We are experiencing service issues. You may encounter failed login attempts, failed matchmaking, or get kicked from a match. We are investigating.
Posted Mar 16, 2018 - 19:44 UTC