x
Get the
Atom Feed
or
RSS Feed
.
PC V-Bucks Purchase Issues
Incident Report for
Epic Games Public
Resolved
The issue preventing players from purchasing V-bucks on PC and Mac has been resolved.
Posted
11
months ago.
Apr
06
,
2018
-
03:50
UTC
Identified
We have identified the issue causing players to be unable to purchase V-bucks on PC and Mac. We are working on a solution.
Posted
11
months ago.
Apr
06
,
2018
-
01:28
UTC
Investigating
We are aware that some players are currently unable to purchase V-bucks on PC and Mac. We are investigating.
Posted
11
months ago.
Apr
06
,
2018
-
00:37
UTC
×
Subscribe to Incident
Subscribe to updates for
PC V-Bucks Purchase Issues
via .