Server Performance Issue
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Mar 09, 2018 - 21:00 UTC
Monitoring
We have removed the affected servers from the fleet and swapped in healthy replacements.
Posted Mar 09, 2018 - 19:00 UTC
Identified
We have identified significant performance issues with a small portion of our server fleet. Matches may experience lag spikes and hitching while we work to resolve the issue.
Posted Mar 09, 2018 - 17:30 UTC