Extended Load Times For Stats/Leaderboards
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted 29 days ago. Feb 21, 2019 - 01:05 UTC
Investigating
Players may experience an increased delay when looking up their stats/leaderboards.
Posted 29 days ago. Feb 21, 2019 - 00:14 UTC
This incident affected: Fortnite (Stats and Leaderboards).