Week 7 Challenge
Incident Report for Epic Games Public
Resolved
At 11:30 am ET, a backend update was deployed to ensure all players received their Week 7 challenges.
Posted 3 months ago. Apr 05, 2018 - 17:50 UTC
Identified
Some players may not see their Week 7 Challenges unlocked. We have identified the issue and are working on a fix.
Posted 3 months ago. Apr 05, 2018 - 09:54 UTC