Services Impacted by Broader Internet Issue
Incident Report for Epic Games Public
Resolved
Epic Games services are no longer impacted by this issue.
Posted Jul 22, 2021 - 18:07 UTC
Update
The status of Epic Games services has improved, but the issue is still ongoing.
Posted Jul 22, 2021 - 17:05 UTC
Identified
A range of Epic Games services are currently impacted by a broader internet issue affecting many other online services.
Posted Jul 22, 2021 - 16:35 UTC
This incident affected: Epic Games Store (Login, Download/Installation, Purchasing/Refunding, Store Browsing) and Fortnite (Game Services, Login, Parties, Friends, and Messaging, Voice Chat, Matchmaking, Stats and Leaderboards, Item Shop, Fortnite Crew).