Degraded Matchmaking
Incident Report for Epic Games Public
Resolved
The issue has been resolved
Posted Mar 15, 2018 - 14:52 UTC
Identified
Players on all platforms may experience errors with matchmaking. Continue to retry joining a match and you should get in.
Posted Mar 15, 2018 - 13:27 UTC