Matchmaking Maintenance
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted 5 months ago. May 31, 2018 - 13:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. May 31, 2018 - 13:22 UTC
Identified
We will be undergoing maintenance during this time to address matchmaking issues.
Posted 5 months ago. May 31, 2018 - 12:30 UTC