Login Issues
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Jun 03, 2022 - 05:29 UTC
Update
We are continuing to investigate this issue.
Posted Jun 03, 2022 - 02:45 UTC
Update
We are continuing to investigate this issue.
Posted Jun 03, 2022 - 01:59 UTC
Update
We are continuing to investigate this issue.
Posted Jun 03, 2022 - 01:58 UTC
Investigating
We are currently investigating this issue.
Posted Jun 03, 2022 - 01:45 UTC
This incident affected: Fall Guys (Login), Epic Games Store (Login), Rocket League (Login), Rocket League Sideswipe (Login), Fortnite (Login), Epic Online Services (Authentication), and Battle Breakers (Login).