Game service is currently experiencing issues
Incident Report for Epic Games Public
Resolved
This has been resolved.
Posted 6 months ago. Apr 05, 2018 - 02:54 UTC
Monitoring
We've identified a problem that impacted a small portion of our servers and shut it down.
Posted 6 months ago. Apr 05, 2018 - 02:20 UTC
Investigating
We're currently investigating an issue that's causing some players to be kicked from matches.
Posted 6 months ago. Apr 05, 2018 - 01:41 UTC