The Baller Temporarily Disabled
Incident Report for Epic Games Public
Resolved
We've collected the data we were looking for and have re-enabled The Baller.

Jump in the driver seat and roll out!
Posted 3 months ago. Mar 18, 2019 - 16:19 UTC
Investigating
We've temporarily disabled The Baller in Battle Royale while we investigate a stability issue.

We'll roll out a status update once we know more.
Posted 3 months ago. Mar 18, 2019 - 14:21 UTC