2FA Emails Not Appearing
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted about 1 month ago. Feb 15, 2019 - 01:48 UTC
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Feb 14, 2019 - 21:42 UTC
This incident affected: Fortnite (Login).