Epic Games Launcher and Website outage
Incident Report for Epic Games Public
Resolved
This issue was fully resolved by 15:45 UTC, Launcher login and epicgames.com access restored
Posted 3 months ago. Dec 12, 2018 - 16:31 UTC
Update
We are continuing to investigate this issue.
Posted 3 months ago. Dec 12, 2018 - 15:39 UTC
Investigating
We are investigating an issue which is blocking login to the Epic Games Launcher as well as epicgames.com. Thank you for your patience while we work toward a resolution
Posted 3 months ago. Dec 12, 2018 - 15:38 UTC
This incident affected: Fortnite (Website and Forums).