Ubisoft Title Install Issues
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 18, 2019 - 00:04 UTC
Investigating
Ubisoft titles recently purchased on the Epic Games Store may not be available to install currently. We're investigating this issue and will provide a status update once it's resolved.
Posted about 1 month ago. Jul 16, 2019 - 23:12 UTC
This incident affected: Epic Games store.