Server Stability - Battle Royale & Creative
Incident Report for Epic Games Public
Resolved
The issues with server stability have been resolved. Thanks for your patience!
Posted 6 months ago. Feb 20, 2019 - 20:56 UTC
Investigating
We’re investigating an issue affecting server stability in Battle Royale and Creative.
Posted 6 months ago. Feb 19, 2019 - 20:40 UTC
This incident affected: Fortnite (Game Services).