MasterCard payment issues
Incident Report for Epic Games Public
Resolved
The issue has now been resolved and payments made with MasterCards should now be processing as expected.
Posted Jul 12, 2018 - 20:13 UTC
Monitoring
We've identified an issue impacting players attempting to make purchases with MasterCard credit cards. We're seeing recovery and payments appear to be once again processing, and we are continuing to monitor the situation. Retrying the payment has shown to resolve the issue.
Posted Jul 12, 2018 - 18:59 UTC
This incident affected: Fortnite (Item Shop).