Epic Games Launcher - Installation & Patching Issues
Incident Report for Epic Games Public
Resolved
The issue preventing some players from patching or installing games on the Epic Games Launcher has been identified and resolved.
Posted Oct 01, 2020 - 14:58 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 01, 2020 - 13:47 UTC
Investigating
We're investigating and working to resolve issues with installing and patching games on the Epic Games Launcher.
Posted Sep 30, 2020 - 17:35 UTC
This incident affected: Epic Games Store (Login).