Epic Launcher Login Errors
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 11, 2018 - 12:53 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Jun 11, 2018 - 12:40 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 2 months ago. Jun 11, 2018 - 12:34 UTC
Investigating
We are currently investigating this issue.
Posted 2 months ago. Jun 11, 2018 - 12:22 UTC