Wick's Bounty LTM - Server Stability
Incident Report for Epic Games Public
Resolved
We've released an update to resolve the stability issues with the Wick's Bounty Limited Time Mode. No download is required.
Posted 4 days ago. May 16, 2019 - 21:37 UTC
Investigating
We're investigating a server stability issue with the Wick's Bounty Limited Time Mode.

We'll provide a status update once it has been resolved.
Posted 4 days ago. May 16, 2019 - 15:25 UTC
This incident affected: Fortnite (Game Services).