Epic Online Services Issue
Incident Report for Epic Games Public
Resolved
Issues with the launcher have been resolved and returned to normal.
Posted May 17, 2020 - 18:34 UTC
Investigating
We are aware that some players are experiencing issues on the Epic Games Launcher and are currently investigating. We’ll provide an update as soon as we can.
Posted May 17, 2020 - 17:42 UTC
This incident affected: Epic Online Services (Authentication).