PlayStation 4 Purchasing Issues
Incident Report for Epic Games Public
Resolved
We've identified and corrected the issue that prevented players from making purchases on PlayStation 4.
Posted 5 months ago. Nov 15, 2018 - 04:01 UTC
Investigating
We are currently investigating some players having purchasing issues on PlayStation 4.
Posted 5 months ago. Nov 15, 2018 - 03:09 UTC
This incident affected: Fortnite (Item Shop).