Email Delivery Delay
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 09, 2018 - 13:06 UTC
Update
We are continuing to monitor for any further issues.
Posted 2 months ago. Oct 09, 2018 - 11:54 UTC
Monitoring
We're aware of an issue that may be impacting the delivery of emails such as those for password resets and authentication, resulting in potential delays. The issue should now be subsiding, and we're actively monitoring to ensure full resolution.
Posted 2 months ago. Oct 09, 2018 - 11:45 UTC
This incident affected: Fortnite (Website and Forums).