Display Names With Linked Steam Accounts Issue
Incident Report for Epic Games Public
Resolved
Thanks for your patience, players with linked Steam accounts for games using EOS should see the correct display name shown in-game.
Posted May 14, 2021 - 21:26 UTC
Investigating
We're aware of an issue where players with linked Steam accounts for games that use EOS may not see their display names properly in-game.

We'll provide an update when this is resolved.
Posted May 14, 2021 - 20:36 UTC
This incident affected: Epic Online Services (Authentication).