Issue With Emails Failing To Deliver
Incident Report for Epic Games Public
Resolved
This issue is resolved, emails should be properly arriving in players' inboxes again.
Posted Apr 14, 2022 - 02:32 UTC
Investigating
We're investigating an issue with our email delivery preventing emails, including 2FA verification and account creation, from properly being delivered to players.

We'll provide an update when service has returned.
Posted Apr 14, 2022 - 01:02 UTC
This incident affected: Epic Online Services (Epic Games Store Ecommerce).