Login Issues - Fortnite/Rocket League/Battle Breakers, Epic Game Store
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 04:11 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 17, 2020 - 04:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2020 - 03:48 UTC
Identified
We are currently investigating log in issues for Fortnite, Rocket League, Battle Breakers, and Epic Game Store.
Posted Nov 17, 2020 - 03:34 UTC
This incident affected: Rocket League (Login), Epic Games Store, Fortnite (Login), and Battle Breakers (Login).