Epic Online Services - Issues with Authentication
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Nov 24, 2020 - 00:01 UTC
Investigating
We are currently investigating issues with EOS Authentication.
Posted Nov 23, 2020 - 23:20 UTC
This incident affected: Epic Online Services (Authentication).