Epic Games Store New Account Creation Issue
Incident Report for Epic Games Public
Resolved
Account creation services have returned to normal.
Posted 26 days ago. Aug 23, 2019 - 21:56 UTC
Update
We are continuing to work on a fix for this issue.
Posted 26 days ago. Aug 23, 2019 - 21:40 UTC
Identified
We're experiencing issues with our account services that may cause issues with creating new accounts and will be rolling out a fix within the hour.
Posted 26 days ago. Aug 23, 2019 - 21:38 UTC
This incident affected: Fortnite (Website and Forums) and Epic Games store.