Rocket League Matchmaking Disruption

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Feb 23, 2025 - 23:30 UTC

Investigating

The matchmaking issues we previously addressed have resurfaced. We're investigating further and will keep you informed with updates as we have them.
Posted Feb 23, 2025 - 20:14 UTC
This incident affected: Rocket League (Matchmaking).