NAE Matchmaking Issues
Incident Report for Epic Games Public
Resolved
We are observing sustained recovery of matchmaking services.
Posted Dec 08, 2021 - 00:14 UTC
Identified
We're experiencing degraded matchmaking rates for players on the NA-East region and working to mitigate the impact.
Posted Dec 07, 2021 - 21:40 UTC
This incident affected: Fortnite (Matchmaking).