EOS Service Issue
Incident Report for Epic Games Public
Resolved
We’ve resolved issues with the Epic Games Launcher and online services. We will continue to monitor and update if anything changes.
Posted May 17, 2020 - 22:51 UTC
Update
We are continuing to investigate this issue.
Posted May 17, 2020 - 21:52 UTC
Update
We are aware that players are experiencing issues with the Epic Games Launcher and online services. We’re investigating, and we’ll provide an update as soon as we can.
Posted May 17, 2020 - 21:06 UTC
Update
We are continuing to investigate this issue.
Posted May 17, 2020 - 20:17 UTC
Investigating
We’re currently investigating online service performance. We will update when we have more information.
Posted May 17, 2020 - 20:15 UTC
This incident affected: Epic Online Services (Developer Portal, Authentication, P2P Networking (STUN/TURN), Matchmaking, Player Data Storage, Stats, Achievements, Leaderboards, Lobbies).