Rocket League Matchmaking Issues

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted May 07, 2025 - 20:09 UTC

Investigating

We are aware of matchmaking issues in Rocket League, we are actively investigating and we’ll provide an update once we know more.
Posted May 07, 2025 - 19:52 UTC
This incident affected: Rocket League (Game Services, Matchmaking, Stats and Leaderboards, Parties, Friends, and Messaging).