Rocket League Log-ins and Matchmaking Issue

Incident Report for Epic Games Public

Resolved

Log-ins and matchmaking are fixed! Players should be able to jump into a match again without issue
Posted Apr 07, 2026 - 16:15 UTC

Investigating

We're working to fix an issue with players connecting to Rocket League, and are restarting our servers. Players will be unable to log-in or connect to a match for a few moments while we resolve this.
Posted Apr 07, 2026 - 15:39 UTC
This incident affected: Rocket League (Login, Matchmaking).