Fab Marketplace Product Detail Page Issues

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 00:53 UTC

Investigating

Fab Marketplace users may be unable to access Product Detail Pages (PDPs). Some listings are displaying an incorrect 'Mature Content' pop-up, and direct PDP links may result in server errors.
Posted Feb 23, 2026 - 23:52 UTC
This incident affected: Fab.