Fall Guys Matchmaking

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Mar 22, 2026 - 04:55 UTC

Investigating

We're investigating an issue with matchmaking that is causing long queue times or failure to find a match for some players.
Posted Mar 22, 2026 - 01:41 UTC
This incident affected: Fall Guys (Matchmaking).