Rocket League - Degraded PsyNet Performance
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Sep 14, 2021 - 01:03 UTC
Update
Post-Match XP and Rewards, Tournament Titles, and Challenge Claims are all experiencing degraded performance or are temporarily offline.
Posted Sep 14, 2021 - 00:12 UTC
Investigating
We are currently investigating this issue.
Posted Sep 13, 2021 - 23:26 UTC
This incident affected: Rocket League (Game Services, Stats and Leaderboards).