Issues with Publishing Tools and Developer Portal

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 06:03 UTC

Investigating

We are currently investigating issues impacting Epic Games Store Publishing Tools and the Epic Online Services Developer Portal. We'll share an update once they are resolved.
Posted Apr 24, 2026 - 05:45 UTC
This incident affected: Epic Online Services (Developer Portal) and Epic Games Store (Publishing Tools).