Rocket League Connection Issues

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 16:37 UTC

Investigating

Rocket League is experiencing matchmaking and general connection issues as we roll over into Season 18. We're investigating and will provide an update once this is resolved.
Posted Mar 14, 2025 - 16:14 UTC
This incident affected: Rocket League (Login, Website, Game Services, Matchmaking, Stats and Leaderboards, Item Shop, Parties, Friends, and Messaging, Voice Chat).