Loading and purchasing issues on the Epic Games Store
Incident Report for Epic Games Public
Resolved
This incident has been resolved.
Posted Dec 17, 2021 - 15:23 UTC
Investigating
We are currently investigating this issue.
Posted Dec 17, 2021 - 14:05 UTC
This incident affected: Epic Games Store (Login, Download/Installation, Purchasing/Refunding, Store Browsing).