Rocket League - Matchmaking Issues 3/8/24
Incident Report for Epic Games Public
Resolved
Rocket League matchmaking issues have been resolved.
Posted Mar 08, 2024 - 19:05 UTC
Investigating
We're aware players are experiencing Matchmaking issues and are currently investigating.
Posted Mar 08, 2024 - 18:20 UTC
This incident affected: Rocket League (Matchmaking).