Scheduled Maintenance - v4.1 Update
Incident Report for Epic Games Public
Resolved
This update is now complete.
Posted 5 months ago. May 08, 2018 - 09:33 UTC
Investigating
Fortnite servers are now offline while we update to v4.1
Posted 5 months ago. May 08, 2018 - 07:53 UTC