EOS Maintenance

Scheduled for Oct 7, 05:00 - 07:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Oct 03, 2025 - 11:37 UTC

Scheduled

Epic Online Services is scheduled for maintenance on Tuesday, 7 October, 5 am UTC. During this maintenance window, there will be up to two hours of degraded availability for the following services:
- Lobbies

We expect (our built-in SDK) retry functionality to limit the impact of this disruption, but Lobbies invites and other functionality may be delayed or fail sporadically.
Posted Oct 01, 2025 - 11:30 UTC
This scheduled maintenance affects: Epic Online Services (Achievements, Lobbies, Sessions).