Rocket League and Rocket League Sideswipe Matchmaking and Login Issues

Incident Report for Epic Games Public

Resolved

This incident has been resolved.
Posted Apr 22, 2025 - 17:58 UTC

Update

We are aware of matchmaking and login issues with Rocket League and Rocket League Sideswipe.
We are actively investigating and we’ll provide an update once we know more.
Posted Apr 22, 2025 - 16:50 UTC

Investigating

We are aware of matchmaking and login issues with Rocket League and Rocket League Sideswipe.
We are actively investigating and we’ll provide an update once we know more.
Posted Apr 22, 2025 - 16:49 UTC
This incident affected: Rocket League (Login, Game Services, Matchmaking, Stats and Leaderboards, Item Shop, Parties, Friends, and Messaging, Voice Chat) and Rocket League Sideswipe (Login, Game Services, Matchmaking, Stats & Leaderboards, Item Shop, Parties, Friends, and Messaging).