NA Champion Kuno & Renzo the Champion FNCS Cup Issue
Incident Report for Epic Games Public
Resolved
We will be rescheduling the NA Champion Kuno & Renzo the Champion FNCS Cup. Please follow along @FortniteStatus on Twitter/X for further updates on the new timings.
Posted Aug 26, 2024 - 18:30 UTC
Identified
We will be raining out the current results and rescheduling the NA Champion Kuno & Renzo the Champion FNCS Cup due to matchmaking errors.

We'll provide details later this week on when this NA event is being rescheduled.
Posted Aug 26, 2024 - 02:51 UTC
Investigating
We’re investigating reports that players are getting a Matchmaking Error when queueing for the current NA Champion Kuno & Renzo the Champion FNCS Cup.

We’re working to resolve this now, and will provide more info on what we’ll be doing to account for this once it’s resolved.
Posted Aug 26, 2024 - 02:17 UTC
This incident affected: Fortnite (Matchmaking).